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Legal Disclaimer 

The product described in this documentation may be connected to, and/or communicate 

information and data via, a network interface, which should be connected to a secure network. 

It is your sole responsibility to ensure a secure connection to the network and to establish and 

maintain appropriate measures (such as but not limited to the installation of firewalls, 

application of authentication measures, encryption of data, installation of antivirus programs, 

etc.) to protect the product, the network, your systems, and the interface against any kind of 

security breach, unauthorised access, interference, intrusion, leakage, damage, or corruption or 

theft of data. We are not liable for damages or losses related to any such security breach, 

unauthorised access, interference, intrusion, leakage, damage, or corruption or theft of data. 
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System Requirements 
Requirements for LinkOne WebView Servers: 
• One of the following operating systems: 

• Microsoft Windows 2008 R2 Server 

• Microsoft Windows 2012 Server 

• Microsoft Windows 2016 Server 

• Microsoft Windows 2019 Server 

• The following are supported for non-production use only. 

• Microsoft Windows 10 

• Microsoft Windows 7 

• Microsoft .NET Framework 4.6 (for WebView) 

• ASP .NET 4 

• Microsoft IIS  7, 8 or 10 

• Microsoft SQL Express 2008 or later  

• Microsoft SQL Server 2008, 2012, 2014, 2016, 2017. 

• 4GB of RAM 

• 200 MB of available hard disk space (plus space for any LinkOne books and notes) 

Minimum Requirements for LinkOne WebView Clients: 

The following versions of the supported browser have been actively tested during the 

development of LinkOne WebView 3.25. Other versions of the supported browsers may operate 

but any issues may be rectified at ABB's discretion. 

Operating System Supported Browser Version 

Microsoft Windows 7,  

10 

Internet Explorer 11, Edge 

Microsoft Windows 7, 

10 

Google Chrome Current version at 

time of release 

testing of LinkOne 

WebView 3.25 

Microsoft Windows 7, 

10 

Firefox Current version at 

time of release 

testing of LinkOne 

WebView 3.25 

Apple OSx 
Safari 5.0.5 

Apple iOS 
Safari Current version at 

time of release 

testing of LinkOne 

WebView 3.25 

Google Android 
Chrome Current version at 

time of release 

testing of LinkOne 

WebView 3.25 

NOTE: 3D Model viewing is currently only supported on Internet Explorer 11 and Firefox. 

Minimum Requirements for Advanced Search: 
• Advanced Search Facility is supported by using a SOLR Server 
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• SOLR index Hard Disk space varies but as a guide, space equivalent to the size of the 

LinkOne libraries is required. 
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Where to Get Help 
The Enterprise Software Online Customer Community 

(https://enterprisesoftware.force.com/customerportal/login) (OCC) provides help for all 

users of LinkOne products. You are encouraged to actively participate in helping other users, 

sharing knowledge and ideas on how you use LinkOne and how you think it can be improved. 

If you have an issue with a LinkOne product, you should first search the OCC to see if any other 

users have encountered this problem to check if there is a solution available. If there is no 

solution already available, post to the appropriate OCC group and supply the following in your 

post: 

• A short description of the problem, including any steps required to reproduce the 

problem. 

• Details of the book you were viewing. If necessary upload a small test book illustrating 

the problem. 

• Any configuration settings you think may have contributed to the problem. 

• Any customizations you may be using with LinkOne. 

• Your current operating system and service packs installed. 

• Any other factors you think are relevant to the issue you are experiencing. 

The LinkOne team will also be monitoring and responding to posts and we will try our best to 

solve any issues before the next release. 

https://enterprisesoftware.force.com/customerportal/login
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Documentation 
LinkOne WebView provides the following documents to help you get started. 

LinkOne WebView 3.25 Release Notes 

The Release Notes contain an overview of what changes are included in the 3.25 release. 

LinkOne WebView 3.24 and earlier Release Notes 

The LinkOne WebView 3.24 and earlier Release Notes contain an overview of the changes are 

included in the versions up to and including the 3.24 release. 

LinkOne WebView Getting Started Guide 

The Getting Started Guide is the starting point for all users of LinkOne WebView. The guide 

provides a quick overview of installation and configuration and new features available in Version 

3. 

LinkOne WebView User Online Help 

This is the online help system for end users, which can be accessed at any time from Help > Help 

on the browser menu. This provides information on features in the LinkOne WebView 

application. 

LinkOne WebView Technical Reference 

The Technical Reference is designed for developers and system administrators who will be 

deploying and integrating LinkOne WebView into their corporate environments. 

Overview 
In this document, you will find information on getting started with LinkOne Publisher 6, 

including installing the software, configuring LinkOne book libraries for viewing in a browser, 

and operating the book viewer with filters and searches. Administration of the web site is also 

included, covering security with users, roles, and policies, as well as managing access levels to 

LinkOne book content. 

If you need further guidance, contact your LinkOne reseller or Enterprise Software Global 

Customer Care (if you purchased LinkOne directly from ABB) via the Customer Portal 
(https://enterprisesoftware.force.com/customerportal/login) or via email 
(mailto:CustomerCare.ES@abb.com). You can get help in answering your questions as well as 

provide feedback and suggestions on the Enterprise Software Online Customer Community 

(https://enterprisesoftware.force.com/customerportal/login) (OCC). 
 

Licensing 
LinkOne WebView requires a license before it can be used. Without a license, only a single user 

from a single browser is permitted. 

A license may be obtained through an authorized LinkOne reseller or by contacting ABB directly 

by emailing LinkOne Administration (mailto:linkone_admin.PGES@abb.com). 

A license is locked to the URL of the LinkOne WebView web site. Once LinkOne WebView is 

installed, login as an administrator, and navigate to Configuration > Site Licenses where the 

web site URL is shown. Use this URL when requesting a license. 

Users of LinkOne WebView 1.x and 2.x will require a new license to operate LinkOne WebView 

3.25. Users with a license from any 3.x version of LinkOne WebView will be able to re-use their 

license with 3.25. 

https://enterprisesoftware.force.com/customerportal/login
mailto:CustomerCare.ES@abb.com
https://enterprisesoftware.force.com/customerportal/login
mailto:linkone_admin.PGES@abb.com
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Viewer Differences 
Whilst LinkOne WebView can serve as a replacement for LinkOne WinView, not all functionality 

available in LinkOne WinView is available in LinkOne WebView. The table below outlines the 

known differences between the two programs, and what features provided in LinkOne WinView 

are available in the WebView product. 

 

Feature WinView V5.x WebView V3.x 

Publisher Linked License 

Required 

Yes No - functions as an Open Viewer 

View Draft Books Yes Yes (from 3.20 onwards) 

Save Search Results Yes No 

Program Notes Yes No 

Printing Yes Yes - for the viewed page/book when the 

Publisher allows it (NB in the case of 

book printing, see the 3.4 Release Notes 

for changes to the config file to enable 

printing) 

Dynamic Derived Books Yes No 

OCI Selection list No - requires plugin Yes 

Access control Yes - using security 

keys 

Yes - using security keys and user 

authentication 

Viewer Customization Yes - using schemes Yes - using themes 

Embedded PDF Links Yes No - use HTML for embedded LinkOne 

links 

LinkOne Links Yes Yes - LinkOne: protocol is required 

 

Installation 
LinkOne WebView 3.25 can be installed using a number of different methods. This section 

guides you through the most commonly used method. For other methods, see the LinkOne 

WebView Technical Reference. 

Use the LinkOne WebView installer application to install LinkOne WebView on your system. 

Before installing, the LinkOne WebView installer will check your system for all features required 

to run. These features are: 

• Microsoft .NET Framework 4 

• Microsoft IIS 7 or above 
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• Microsoft SQL Express 2008 or later. Note: When using SQL Server rather than SQL Express, 

the installer must be run with the VERSIONSQLSERVER option. Please refer to the 

Installation section of the LinkOne WebView Technical Reference for more information 

These components are all free from Microsoft, and are either pre-installed with Windows, or 

available for download from the Microsoft Web site. 

Note: LinkOne WebView is a 32bit web application which can be installed on 64bit versions of 

supported Windows operating systems.  

Prerequisites Install 
Ensure all prerequisite features are installed and up to date by using the Microsoft Web 

Platform Installer with the following steps. 

NOTE: Sometimes, the Microsoft Web Platform Installer may not supply all the prerequisites, 

for example- SQL Server. You may have to download/install SQL Server or SQL Server 

Express Manually. 

1. Download and run the Microsoft Web Platform Installer from the Microsoft Web Platform 

(http://www.microsoft.com/web/downloads/platform.aspx) Web site. 

2. Select the recommended products from Web Server, Frameworks and Runtimes, and 

Database by clicking the Click to include the recommended products for each component. 

Click Install. 

 

http://www.microsoft.com/web/downloads/platform.aspx
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3. If SQL Server Express is to be installed, you will be asked to choose an authentication type. 

Select Windows Integrated Authentication. Click Continue. 

 
4. The installation will now start, and you may be asked to restart to continue. After any 

restart, log in, and the installation will continue automatically. 

Once installation has completed, close the Web Platform Installer and start the LinkOne 

WebView Installer. If you are on Server 2008 please make sure that the Web Server Role has been 

installed AND that the ASP.NET Role Service has been installed. 

LinkOne WebView Install 
1. Double-click the LinkOne WebView installer application to launch the installation wizard. The 

wizard then examines your system configuration. 

 

If your system meets all necessary requirements, the welcome window displays. Click Next 

to begin installing LinkOne WebView. 

 
2. If you get an error message indicating that you need to install Asp.Net 4 and it is already 

installed, you need to register Asp.Net 4 by opening a command window and running the 

command  
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•  aspnet_regiis -i 

from the appropriate directory, for example c:\Windows\Microsoft 

.NET\Framework\v4.0.30319 

3. You must read and accept the software license agreement before you can install LinkOne 

WebView. Select the option to accept the license agreement. Click Next to continue. 

 
4. Enter the user name and organization for the primary owner of LinkOne WebView. Click Next 

to continue. 
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5. Select an installation Web site. Select a root Web site from the list of available Web sites on 

the server. Then enter a unique name for the Web site folder. The sample shown will resolve 

to http://localhost/linkone. Click Next to continue. 

 
6. The default installation folder shown is resolved from the folder of the selected Web site, 

and the Web site folder you entered in the previous step. To change the location of where 

the files are installed, click Change and refer to next section. Click Next to continue. 
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7. You can change the default destination folder by navigating to the required location. Press 

OK when the selected location is determined or Cancel if the current location is to be kept. 

The display will return to the previous screen as shown in section 6 above. 

 
8. Once installed, the only access to LinkOne WebView is through a web browser pointed at 

the address chosen in step 5. You can select Create Start Menu Shortcuts and install a 

shortcut on the Start menu that launches a browser at that address. Click Next to continue. 
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9. Click Install to commence installing LinkOne WebView with the options you selected. 

 
10. After the installation is complete, click Finish to close the installation wizard. If you want the 

web site to launch, leave the check box ticked. 

 

Post Installation Configuration 
After you have installed WebView, there are a number of tasks that must be performed prior to 

running WebView, for example enabling HTTPS.  

These tasks are described in the Walkthroughs section of the LinkOne WebView Technical 

Reference. Please review these sections to determine which are applicable to your situation. 

Note: If you installed onto Windows Server 2012 and users are receiving the error "Could not 

load picture data from server", please check that HTTP Activation is installed. This can be done 

from the Add Roles and Features Wizard by selecting "Features/.NET Framework 4.5 

Features/WCF Services/HTTP Activation" 

Note: If you are installing onto a machine running IIS 7 and the background image does not 

appear on the login page, you will need to modify web.config. This task is described in the 

Walkthroughs/How to Configure IIS 7 section of the LinkOne WebView Technical Reference. 
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Operation 
User Login 
Users are required to login to LinkOne WebView for the purpose of licensing and to identify the 

books that are allowed to be viewed. 

Log in to the web site using the site address chosen at installation, for example 

http://localhost/linkone if you are browsing on the same server that LinkOne WebView was 

installed on. During installation a shortcut may have been created on the Start Menu that takes 

the user directly to the login page. 

A single user login account is created during the installation. If this account has not been 

changed, its credentials are: 

• User Name: user 

• Password: user 

Additional login fields are shown by clicking the login panel title bar. These login fields can be 

left at their default values, or they can be set to preferred values for starting the session. 

• Book Language: Select the language of the viewed book content. If the book has no content 

in that language, then the book default language is shown. 

• Web Site Theme: Select the colour theme for the Web site. Two themes are created at 

installation time. 

• Selection List: This chooses the selection list type for the session from the list of configured 

selection list types. 

• Selection List Name: Choose the selection list name for the session, which is where any 

selected parts are stored. This is the same as using the Save As menu entry when viewing a 

book. 

• Show Superseded Entries: This acts as a filter of the book content to show superseded 

parts list entries. This option only has an effect if the book publisher has included 

superseded parts in the book. 

When you login, the Browse Books web page displays all LinkOne books that are available to 

view. The menu also shows choices to view the current user profile, and to show the online help. 

As part of the initial configuration, it is recommended that the password for user name user is 

modified from the delivered password 

User Profile 
The My Profile web page is a private page for each user allowing them to change their 

passwords and let them view and manage any private selection lists that they have saved. 

If a user changes their password on their My Profile page, the new password must conform to 

the password strength requirements of the Web site. 

The selection lists shown on this page are the private selection lists for the selection list type 

selected when the user logged in. 

Tasks 

To delete a selection list, click Delete next to the unwanted entry. A prompt will display 

confirming the delete request. Click OK to delete. 

To delete a part from a selection list, click a selection list to show the parts, and then click 

Delete next to the unwanted part. 
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To jump to a part view, click a selection list to show the parts, and then click a part to navigate 

to the book view. 

Book Browsing 
All books that the current user can open are displayed on the Browse Books web page. The 

books are organized in hierarchical folders, starting with book publishers at the top level. 

Clicking on a publisher folder expands that publisher to show book category folders and books 

for that publisher. 

The Web site administrator chooses which books can be seen by a user. 

When a book is opened, any licenses required to open the book are checked against the licenses 

assigned to you. Security Key Required displays if no correct license is found. 

Viewing Books 
To view a book, navigate to Browse Books, and select a book from the list of available books. 

The main book viewing web page opens and displays the opening page set by the publisher. 

When viewing a book, the content can be: 

• Navigated using the menu or the Table of Contents. 

• Selected into the Selection List for ordering. 

• Filtered to show only relevant information. 

• Searched to locate parts or pages. 

• Printed in the publisher defined format. 

• Annotated with notes for additional information not found in the book. 

Viewer Layout 
When you open a book the main book viewing web page displays. 

 

 

The panels in the book viewer are: 

1. Table of Contents Panel 
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2. Book Menu 

3. Pictures Panel 

4. Parts List Panel 

5. Selection List Menu 

6. Selection List Panel 

7. Picture Menu 

The initial page which is viewed when you open a book, is set by the book publisher. To open 

another page, either click directly on a page in the Table of Contents, or click on the Next Page, 

Previous Page, or Parent Page buttons (the blue and white buttons). The content of each page 

is also set by the book publisher, and occupies the Pictures and Parts List panels on the right 

side of the book viewer. 

Tasks 

To hide or show any of the panels, click on View and then click on Contents, Pictures, Parts, or 

Selection List. 

To resize a panel, drag the divider adjacent to the panel being resized to the desired location 

and release it. 

To restore panel sizes, click View > Reset Layout. 

Table of Contents Panel 

The Table of Contents panel is docked on the left of the book viewer page.  To toggle the panel 

on or off, click View > Table of Contents. 

The table of contents shows the full hierarchy of pages found in the book, excluding any 

filtered-out pages. Each page is listed with its title, page number, and page reference (the page 

reference is hidden if all references match their page numbers). Click on a parent page to 

expand that page to show its child pages. 

Tasks 

Click on a page to navigate to that page directly.  You can also click on Next Page, Previous 

Page, or Parent Page. 

Pictures Panel 

The Pictures panel is docked in the middle of the Book viewer web page. The panel expands to 

fill the Parts List panel when no parts are present for the viewed book page. The panel collapses 

when no pictures are present for the viewed book page. 

Hover over the picture with the mouse pointer to display a toolbar. To pin the toolbar click the 

Pin / Unpin icon. 

Tasks 

To zoom on the picture either: 

• Scroll the mouse wheel when hovering over the picture. 

• Click the Zoom In, Zoom Out, or Zoom Fit icons. 

• Click the Zoom Mode icon, then press the left mouse button, drag and release the mouse on 

the picture to perform a rubber band zoom. 

• Click the Pan Mode icon, press the CTRL key down, press the left mouse button, and drag 

and release the mouse on the picture. 

To pan the picture when it is zoomed in, either: 

• Click the Pan Mode icon, then click and drag the mouse on the picture. 
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• Click the Zoom Mode icon, then press the Shift key down and click and drag the mouse on 

the picture. 

Double-clicking on a callout on the picture adds the associated part to the selection list. 

Additional clicks on the callout increase the quantity of the part in the selection list. 

To select a different picture found in the page, click Next Picture or Previous Picture or choose 

from the list of available pictures. These tools will be disabled if only one picture is on the page. 

Parts List Panel 

The Parts List panel is docked to the right of the book viewer page. This panel can also expand 

to fill the Pictures panel when no pictures are present for the viewed page, or it can collapse 

when no parts are present for the viewed page. 

The type of content shown by the parts list is set by the publisher, but is usually either: 

• A list of parts, with each part associated with a callout on a picture. 

• A PDF document. 

• An HTML document. 

• An XML/XSL document. 

• An external Web site 

The layout of the parts list is set by the book publisher. If the publisher has allowed other 

layouts to be chosen, view these layouts by clicking View > Preferences and selecting a new 

Screen Layout. 

Click on the shopping basket icon in the parts list to add the adjacent part to the selection list. 

Additional clicks on the shopping basket will increase the quantity of the part in the selection 

list. 

In separate panels above the parts list are: 

• Related Pages - A list of pages related to the current page (if any exist). Click a related page 

to jump to that page. 

• List Notes - A list of notes flagged as List Notes. Click a note title to show that note. 

Selection List Panel 

The Selection List panel is docked at the bottom of the browser, and lists all parts that have 

been selected from the Parts List or Picture. The columns that display and the menu 

functionality are based on the type of selection list chosen at log in. The administrator controls 

which columns display for each selection list type, and which parts list fields are mapped to 

which columns when a part is added. For more information, see the LinkOne WebView Technical 
Reference. 

Tasks 

To add a part to the selection list, either: 

• Click the shopping basket icon in the parts list that is next to the wanted part (a part will 

only have a shopping basket icon if it satisfies the selection criteria. See the LinkOne 
WebView Technical Reference); 

• Double click a picture callout; 

• Click Add Blank if available with the selection list chosen at login, and enter the required 

fields. 

To delete a part from the selection list, click Delete next to the unwanted part. 

To modify the quantity of a part in the selection list, either: 

• Add the part again to increase the quantity; 
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• Directly modify the quantity by clicking Edit next to the relevant part, update the quantity 

and click Save. 

To order the selection list by a specific column, click the column title. This will cycle through 

ascending, descending, and added order. 

To save the selection list with a new name, click Save As, and enter a new name. 

To open a saved selection list, click Selection Lists.  Select from the list of available names. 

To delete a saved selection list, click Selection Lists. Click Delete next to the unwanted selection 

list. 

Filtering Content 
A book can contain information for a range of models, versions and variants of a piece of 

equipment. If the book publisher has set options for a book, those filters hide irrelevant 

information, so that only the needed information is displayed. 

To filter information, specify the option values that are relevant for the wanted content (for 

example, the serial number, torque converter and cold-weather variant). LinkOne WebView will 

then hide any data that is not relevant to the selected filters. 

For example, for a piece of equipment that has a serial number of 20013 and is part of a 

cold-weather model, you could define two filters: 

• The Serial Number option with a value of "20013". 

• The Cold Weather option (if this was defined by the publisher) with the value "ON". 

Any page content marked as being only for serial numbers other than "20013", or marked as 

being only for non-cold-weather models is hidden. Content that does not have the option you 

specified a value for, is still visible. 

If a page is hidden as a result of filtering, the page title is not displayed in the Table of Contents 

panel. The page and any of the entries on the page will not be found in any search. Any links on 

other pages that link to the hidden page are also hidden. 

The publisher can tag pages or parts with several different filter options, or more than one 

instance of the same code. For example, a part that is relevant to three different serial numbers, 

or to two different possible cold weather options. When there are several instances of the same 

option for a part, you only need to match any one of them in your filter for the content to 

display. Filtering does not work if the publisher has not placed option codes in the book. 

Tasks 

To apply a filter to the current book: 

1. On the book viewer page, click Filters > Temporary. The Temporary Filters window displays. 

2. Enter the filter value for the wanted option. Click OK to close the window and apply the 

filters. 

To apply a filter to the current viewed book permanently: 

1. On the book viewer page, click Filters > Permanent. The Permanent Filters window displays. 

2. Click New Permanent Filter. 

3. Enter the wanted filter value and option. 

4. Select the Access level for who should have the filter applied. 

5. Select the Location level for where to have the filter applied. 
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Searching 
You can use LinkOne WebView to locate information in a LinkOne book by searching for data 

such as page titles, part descriptions, or part numbers. 

When matching search values to data in the book, the book search engine typically ignores 

punctuation, spaces and other characters defined by the book publisher. A publisher, however, 

may specify that punctuation or spaces are allowed in a particular search value. Bracketed text 

in descriptions is usually not found by searches. Again, the publisher controls this behaviour. 

Tasks 

To perform a LinkOne WebView search: 

• On the book viewer page, click Search. The Search window displays. 

• In the Search With field, select the type of search you want to use. If additional searches 

have not been defined by the book publisher, then only the default searches are available. 

• In the Search In field, select the range of data to search. The search can cover all books, or 

be limited to the current book or the current publisher. NB if the Advanced Search Facility is 

enabled, the ability to search all books is not available from here. 

• In the field for the parameter on which to search (for example, the Part Number field), enter 

the value to search on. If the entire value is not known, a partial number can be entered. For 

example, 9901 can be used to find all part numbers starting with 9901. 

• Click Search. The search results display in the right panel of the Search window, showing the 

exact text that was matched and details of the matching book and page. 

• Click any of the listed results to display the entry details. 

Advanced Search Facility 
You can use the Advanced Search Facility (if it has been configured and enabled by the System 

Administrator) to locate information across multiple LinkOne books by searching for data such 

as page titles, part descriptions, or part numbers. The Advanced Search Facility replaces the 

multi-book search option in the WebView Search dialog. It is a high performance search relying 

on the LinkOne books being indexed before the Search is run. 

You can only search on the books that the System Administrator has allowed you access to. 

The Advanced Search Facility can be used as a Quick Search or as a Filtered Search. A Quick 

Search searches all books the user has access to and all fields in these books. The Filtered 

Search allows the search to be limited to all fields in specified books or specified fields in 

specified books. 

Tasks 

To use as a Quick Search: 

• On the Browse Books page, type the search text into the Library Search Text box on the 

Menu bar. 

• Click the Search icon (binoculars) 

• The Advanced Library Search page will be displayed with the results of the search. 

• Click any of the listed results to display the location of the search match. 

To use as a Filtered Search: 

• On the Browse Books page, click the Advanced button on the Menu bar. 

• The Advanced Library Search page is displayed showing a list of Publishers and Books the 

user has access to. 

• Select the Publishers/Books to be included in the search. 
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• Open the Select Fields to Search panel and type the text to search on against the relevant 

Field/s, or 

• Open the Search All Fields panel and type the text to search on in the Search All box. 

• Click the Search icon or Search link on the appropriate panel to execute the search 

• The results will be displayed on the same page. 

• Click any of the listed results to display the location of the search match. 
 

Creating Notes 
You can use LinkOne WebView to supplement book content with user notes. There are several 

types of notes that can be created, and each note can be assigned an accessibility level for 

restricting who can view the note. Each note can also be located anywhere, from the library for 

global viewing, down to an individual part for viewing anywhere that part is seen. 

The Administrator defines who can create notes, where the notes can be created, and what 

language the note is created for. 

The types of notes that can be created are: 

• Text Note - Write comments and extra information. 

• Cross Reference Note - Create additional cross-reference links between pages. 

• Bookmark - Mark a location in a book to return to. 

• Hyperlink - Create a link to a URL. 

The access level for each note can be: 

• Public - Visible to anyone who accesses the book. 

• Private - Visible to only the creator of the note. 

• Supplied - Supplied notes are visible to anyone who can access the book. 

The location of each note determines where the note is shown, and can be: 

• Global - Shown on every page. 

• Publisher - Shown when viewing any page in any book from the publisher. 

• Book - Shown when viewing any page in the book. 

• Page - Shown when viewing the page. 

• Publisher Part - Shown on the part, everywhere in the publisher. 

• Book Part - Shown on the part, everywhere in the book. 

• Page Part - Shown on the part, everywhere on the page. 

• Page Item - Shown on the item, on the page. 

For more information on the functionality of each note type, the note access level, and the note 

location, click Help > Help. 

If notes are visible for the page being viewed, then they are seen as menu buttons on the book 

web page. Click on a note menu button to display the associated note. A note can also be 

created to automatically display when the page or book is opened. For more information on 

when a note is shown, please see the online help guide by clicking Help > Help. 

Tasks 

To create a note: 

1. Click Notes > Notes. The Notes web page displays.  

2. Click the appropriate button for the type of note to create (for example to create a text 

note, click New Text Note . 

3. Enter the note information in the empty fields. 
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4. For advanced settings, adjust the note behaviour, the note access, and the note location. 

5. Set a note category to group the note menu button under a menu for the chosen category. 

6. Set a language to display that note only for users logged in with that language. 

7. Click OK to save the note, and make it appear on the book menu 

Administration 
Before using LinkOne Publisher, an administrator will configure the Web site with books to view, 

along with associated licenses, and accounts for users to login. 

LinkOne Publisher is administered directly through the Web site, and allows full administration 

of user accounts, user roles, licenses, policies, accessibility, and book libraries. 

Administrator Login 
Administrators log in through the main Web site login page. 

A single administrator login account is created during installation. If this has not been changed, 

then the following credentials are available: 

• User Name: admin 

• Password: admin 

All other login fields can be left at their default values. 

Once logged in as administrator, several configuration menus are available that are only visible 

to users in the Administrators role. The administration functions available are described in the 

following sections. 

As part of the initial configuration, it is recommended that the password for the admin user is 

modified from the delivered password. It is recommended that at least 2 users have the 

Administrators role. 

Server Management 
Site Licenses 
A site license for one concurrent user is included with LinkOne WebView. New site licenses can 

be added at any time to increase this number, allowing more users to use the Web site 

concurrently. 

A LinkOne WebView site license identifies: 

• A single nominated site (the hosting URL) from which the LinkOne WebView Web site is 

served. 

• The number of concurrent users permitted to simultaneously connect to the Web site. 

Additional site licenses may be obtained from ABB or your authorized LinkOne reseller. Use the 

site name identified under the list of site licenses when requesting any new licenses. 

Tasks 

To view all site licenses, log in as an administrator, and select Configuration > Site Licenses. All 

licenses are shown, including their licensed concurrent user count, their licensed URL to serve 

from, and any remaining time limit on the license. 

To add a site license, enter your new license into the empty license field, and click Add. 

To delete a site license, click Delete adjacent to the unwanted license. A prompt will ask you to 

confirm the request to delete the licence, Click Ok. 
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Concurrent Licensing 
To accurately predict the concurrent user capacity required for a LinkOne WebView installation, 

you need to understand how LinkOne WebView defines a "concurrent user". 

LinkOne WebView defines a concurrent user as a single active connection between a web 

browser and the LinkOne WebView web site. 

When a LinkOne WebView session is established, a single concurrent user license is consumed. 

The license is held exclusively by that LinkOne WebView session until the session has been 

inactive for 15 minutes. After this time, the license is released, and becomes available for use by 

other LinkOne WebView sessions. If the session becomes active again after 15 minutes, it 

attempts to consume a new license. 

The current session usage of the Web site is available for viewing by using the login report. 

Tasks 

To view the current license usage report, lo gin as an administrator. Navigate to Reports > 

Login Statistics. 

Reports 
LinkOne WebView routinely logs activity, and also reports errors if any occur. How long these 

logs are kept, and where errors are reported to, is defined in the reporting configuration page. 

Tasks 

To view the reporting configuration, log in as an administrator. Navigate to Configuration > 

Reporting. 

To choose a new folder for error report storage, enter a folder name, and click Save. 

To choose the period of time log activity is kept, enter a new period, and click Save. 

Reporting 
Login Activity 
The Login Activity report page at ~/Reports/LoginActivity.aspx shows the total number of 

licensed tokens on the web site, and the currently used number of tokens. The chart shows the 

historical usage of tokens for the nominated period. All times are in the server time zone. 

Tasks 

To nominate a new chart period, enter the required date and time range and click Refresh. 

Click on any of the predefined time periods to redraw the chart for that period. 

Click on Export to download the time and tokens used in CSV format. 

User Activity 
The User Activity report page at ~/Reports/UserActivity.aspx lists login and LinkOne page 

viewing activity for all users that logged in during a specified time. A login is defined as a new 

browser session, and a page view is defined as a change to a new page. All times are in the 

server time zone. 

Tasks 

To nominate a new list period, enter the required date range and click Refresh. 

Click on any of the predefined time periods to re-list for that period. 



LinkOne WebView Getting Started Guide 

 

27 

 

Click on Export to download the logins and times in CSV format. 

Book Activity 
The Book Activity report page at ~/Reports/BookActivity.aspx lists page usage and viewing 

activity for all books viewed during a specified time. The book is identified as its publisher 

code/book code. The page usage count is for all pages viewed, and not just unique pages 

viewed. All times are in the server time zone. 

Tasks 

To nominate a new list period, enter the required date range and click Refresh. 

Click on any of the predefined time periods to re-list for that period. 

Click on Export to download the books and times in CSV format. 

Advanced Search Facility 
Before the Advanced Search Facility can be used, the libraries must be indexed. This is done by 

configuring and running the ~/bin/LinkOneBookIndexingService.exe Windows Service on the 

web server in tandem with a SOLR server that manages the index data. 

The LinkOneBookIndexingService indexes all the libraries specified in the 

Services.BookService.Libraries key found in the ~/Mincom.LinkOne.WebView.config file. 

Whenever any book in the libraries is changed, or a book is deleted, or a new book is added, the 

service will update the indexes. 

See the LinkOne WebView Technical Reference for detailed instructions for setup and 

configuration of your system in order to support the Advanced Search Facility. 
 

Book Change Notification 
The Book Change Notification system can be configured to allow users to subscribe to receive 

emails when books change. 

This functionality is facilitated by the "LinkOneNotificationService" Windows Service, which 

'listens' to each configured library in WebView. As a result of the way this functionality must 

work, the service also requires write permissions to each library folder. 

The Book Change Notification Service does not notify when changes occur to documents stored 

within SharePoint. For more information, please refer to the SharePoint Alerts section of the 

LinkOne WebView Technical Reference. 

Settings 

LinkOneNotificationService 

The LinkOneNotificationService is configured through the 

LinkOneNotificationService.exe.config file located in the ~/Bin directory 

The LinkOneNotificationService reads the WebView configuration files in order to determine the 

library list as well as the sql server connection strings and therefore needs to be configured with 

the location of the WebView LinkOne folder for example- 

 <add key="Mincom.LinkOne.WebView.LinkOneDir" value="c:\inetpub\wwwroot\linkone" 

/> 

The email settings are configured in the LinkOneNotificationService.exe.config as follows: 

 <mailSettings> 

  <smtp from="admin@acme.com"> 
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   <network host="mail.acme.com" port="25" userName="fred" 

password="password" defaultCredentials="true" /> 

  </smtp> 

 </mailSettings> 

Where: 

 admin@acme.com is the email address the notification emails will be from. 

 mail.acme.com is the smtp mail server address. 

 fred is the user to login to the mail server as. 

 password is the password to login with. 

To test that the email functionality is working, please configure the administrators email (or a 

test email address) using the "Mincom.LinkOne.WebView.TestEmailAddress". This email 

address will receive an email when the windows service is started. 

Email Subject and Text 

The text which is emailed when a book change is detected is configured by editing the 

EmailBodyTemplate.txt and EmailSubjectTemplate.txt files under the ~/App_Data folder. 

The EmailSubjectTemplate.txt file contains the text used for the Subject line of the email. It 

should be limited to 1 line of text. 

In the EmailBodyTemplate.txt, several tokens are used 

• <UserName> represents the username 

• <PublisherCode> the publisher code 

• <BookCode> the book code. 

Note: After making modifications to the template files, you must restart the 

LinkOneNotification Service. 

Tasks 

The LinkOneNotificationService needs to be installed as a windows service by opening a 

command prompt where the LinkOneNotificationService.exe is located (linkone\bin by default) 

and executing the following command: 

 c:\Windows\Microsoft.NET\Framework\v2.0.50727\Installutil 

LinkOneNotificationService.exe 

Note: In a multi LinkOne server environment (with shared content/books) the notification 

service should only be run on one server. 

Once installed the service must be configured to run under an appropriate account which has 

write/create access to all configured library folders by using the Services snap-in under 

Windows. 

To ensure stability of the notification system it is recommended that a daily scheduled task be 

configured under windows to restart the LinkOneNotificationService. An example would be to 

create a batch file containing the following commands and scheduled to run daily at midnight. 

 net stop LinkOneNotificationService 

 net start LinkOneNotificationService 
 

User Management 
User management involves configuring named user accounts for login, and assigning licenses, 

policies, and book access for each user. For bulk management of users, roles are used and 
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assigned to users, with a role having the relevant licenses, policies, and book access to be 

shared by the users in that role. 

Each user can log in and change their password through the My Profile web page. An 

administrator can also reset a user's password on the Configuration > Users web page. 

The standard installation includes two user accounts: 

• User 

• Admin 

Users are managed by the Microsoft Asp.net membership provider using a private membership 

database. For other user management options, such as Active Directory, refer to the LinkOne 

WebView Technical Reference. 

Tasks 

To view the configured users, log in as an administrator, and navigate to Configuration > Users. 

Each configured user consists of a unique name, and status information on last login and 

activity. 

To add a user, enter the details in the empty fields, and click Add. 

To delete a user, click Delete next to the unwanted entry. A prompt will display confirming the 

request to delete. Click OK. 

To modify a user, click on the row of the entry to modify and make the necessary changes. Click 

on Save. 

When modifying a user's details, the following properties can be changed: 

• Roles: A list of all roles to which the user belongs. All licenses, book access, note access, and 

policies are inherited from any roles to which the user is assigned, in addition to those 

added specifically to the user. 

• Licenses: A list of relevant licenses required to open any books the user is allowed to view. 

• Allowed Books: A list of books the user can browse and open. A user can be granted access 

to all books in the library, or a specific book, or a specific category of books, or all books 

from a specific publisher. 

• Allowed Notes: A list of note categories that the user can view. A user can be granted access 

to all notes in the library, or a specific category of notes if a category is added. 

• Policies: A user can be granted specific rights, which will override any rights from the roles 

to which the user is assigned. 

Role Management 
Roles are used to assign licenses, policies, and accessibility that are common to several users. 

Assigning a role to several users dispenses with the need to individually configure each user the 

same way. Multiple roles can be assigned to a user, and the user then inherits all licenses, 

policies, and accessibility for those roles. 

The standard installation includes two roles: 

• Users 

• Administrators: a special role that is granted access to the Configuration and Reporting 

web pages 

Tasks 

To view the configured roles, log in as an administrator. Navigate to Configuration > Roles. 

Each role consists of a unique name, and status information on how many users are assigned to 

that role. 

To add a role, enter the details in the empty fields, and click Add. 
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To delete a role, click Delete next to the unwanted entry. A prompt will display. Click OK. 

To modify a role, click on the row of the entry to modify and make the necessary changes. Click 

Save. 

When modifying a role's details, the following properties can be changed: 

• Users: The users that have been assigned to this role and will inherit all licenses, book 

access, note access, and policies from the role. 

• Licenses: The licenses to open books that users in the role have access to. 

• Allowed Books: A role can be granted access to all books in the library, or a specific book, or 

a specific category of books, or all books from a specific publisher. 

• Allowed Notes: A role can be granted access to all notes in the library, or a specific category 

of notes. 

• Policies: A role can be granted user rights, which can also be overridden for a user by any 

specific rights granted to that user in the role. 

Library Management 
LinkOne WebView can display any LinkOne book that is found in an indexed LinkOne book 

library. Multiple libraries can be added to the Web site, and these libraries can be the same as 

those that are used for LinkOne WinView. 

LinkOne book libraries must be fully indexed to be able to view books contained within. This is 

not a requirement for LinkOne WinView, and so even if libraries are shared, they should be 

reindexed after they are added to LinkOne WebView. 

The order of a library is important when the same book is found in more than one library. In this 

case, the book that is found in the library that is higher in the library list will be used. 

Each library has an indicator icon which shows: 

• Online: An indexed library has been found and is being used. 

• Offline: The library folder was not found. 

• Not Indexed: A library was found, but no index was found. 

Tasks 

To view the configured libraries, log in as an administrator. Navigate to Configuration > 

Libraries. Each configured library consists of a unique library folder, an ordered position in the 

full library list, and an enabled state. 

To add a library, enter the folder name in the empty folder field, and click Add. If the folder is on 

a network file share, then use its UNC path. If the folder is a local library, then drive letters are 

ok. In all cases, the Web site account (the built-in Network Service account) must have access to 

the library folder. 

To delete a library, click Delete next to the unwanted entry. A prompt will display requsting 

confirmation to delete the library. Click OK. 

To reindex a library, click Reindex next to the relevant entry, and wait for notification of 

reindexing complete. You must reindex a library after adding new books to that library. 

To enable or disable all books in a library, click the Enabled check box of the relevant library to 

change the enabled state. Disabling a library will hide all books in that library from all users 

when browsing books. 

To modify the order of a library in the list, click Move Library Up or Move Library Down. 

Settings 

As you browse the libraries and open books, LinkOne WebView caches content for speedier 

access. The content cache can be selected here, and defaults to a cache folder in the Web site. 
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Each book is decoded according to the web server code page, or the published book code page. 

The default code page for decoding can be chosen here, and defaults to the code page of the 

web server. 

Make the required changes and click Save. 

Note Management 
Notes that are added to LinkOne books by their publisher are called supplied notes. You can 

also create your own private notes for private viewing, or public notes that other users can 

view. 

Manage where these notes are stored using the note configuration web page. On this page, a 

single folder is chosen for storing all public notes. A single folder is also chosen for private 

notes, and the private notes are then stored in a sub-folder per user. The name of the user is 

embedded in the chosen private notes folder by including {0} where the user name will be 

substituted. 

Tasks 

To view the note configuration, log in as an administrator. Navigate to Configuration > Notes. 

To choose a new folder for public notes, enter a folder name, and click Save. 

To choose a new folder for private notes, enter a folder name including {0} for the user name 

substitution, and click Save. 

Selection List Management 
Each login session requires a selection list for the user to add selected parts to. The user 

chooses their selection list type when they log in. The administrator determines the available 

selection lists, and how they behave. 

The standard install contains the following sample selection lists. 

• Default: A selection list that maps the common parts list fields to the selection list. 

• OCI: A selection list that conforms to the Open Catalog Interface used by SAP. 

• SamplePricing: A selection list that shows mock prices for parts added. 

Selection lists may share their web pages to offer the same look and feel, by using the same 

location. Alternatively, a selection list location may be cloned into a new location, modified, and 

then added to the configured selection lists using the new location. 

For more information on customizing selection lists, refer to the LinkOne WebView Technical 
Reference. 

Tasks 

To view the configuration of selection lists, log in as an administrator. Navigate to 

Configuration > Selection Lists. Each selection list consists of a unique name, a location in the 

Web site of where the web pages for the selection list are found, and a flag to indicate whether 

the selection list is stored between sessions for the user. 

To add a selection list, enter the details in the empty fields, and click Add. 

To delete a selection list, click Delete next to the unwanted entry. A prompt will display 

requesting confirmation of the delete request.  Click OK. 

To modify a selection list, click on the row of the entry to modify and make the necessary 

changes. Click Save when complete. 
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Assigning Security Keys 
LinkOne WebView will open any book not locked by its publisher. When a publisher locks a book, 

the matching security key must be used to unlock that book's content. Locks may be placed on 

entire books, on any pages in a book, on parts list layouts, or on book searches. 

Security Keys can be assigned to a specific user or to a role. 

Tasks 

To assign a Security Key to a user: 

1. Login as an administrator. Navigate to Configuration > Users. 

2. Select a user by clicking on the row of the entry to modify. 

3. Select the Licenses details. 

4. Enter a new Security Key in the empty Security Key field, click Add. 

To assign a Security Key to a role: 

1. Login as an administrator. Navigate to Configuration > Roles. 

2. Select a role by clicking on the row of the entry to modify. 

3. Select the Licenses details. 

4. Enter a new Security Key in the empty Security Key field, click Add. 

Assigning Book Access 
An administrator determines what books each user or role can browse and open. 

The full set of books available for browsing comes from the list of all configured and enabled 

book libraries. Each user can be allowed to browse the full set of books, or a reduced set by 

allowing access with a combination of: 

• All books from a specific publisher 

• All books from a specific category of books from a publisher 

• A specific book 

This access can be assigned to a specific user, or to a role shared by several users. 

Tasks 

To assign access to a user: 

1. Log in as an administrator. Navigate to Configuration > Users. 

2. Select a user by clicking on the row of the entry to modify. 

3. Select the Allowed Books details. Perform one of the following: 

a. Select All Books; 

b. Click on Select Book and select a book, a category, or a publisher from the library, then 

click OK, then click Add. 

To assign access to a role: 

1. Log in as an administrator. Navigate to Configuration > Roles. 

2. Select a role by clicking on the row of the entry to modify. 

3. Select the Allowed Books details. Perform one of the following: 

a. Select All Books; 

b. Click on Select Book and select a book, a category, or a publisher from the library, then 

click OK, then click Add. 
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Assigning Note Access 
An administrator determines what notes each user or role can view. 

The full set of notes available for viewing comes from the list of all supplied, private, and public 

notes found for the current book view. Each user can be allowed to view the full set of notes, or 

a reduced set by allowing access with a combination of: 

• All notes from a specific category of notes 

This access can be assigned to a specific user or to a role shared by several users. 

Tasks 

To assign access to a user: 

1. Log in as an administrator. Navigate to Configuration > Users. 

2. Select a user by clicking on the row of the entry to modify. 

3. Select the Allowed Notes details. 

4. Either select All Notes or enter a note category code to grant access to notes in a specific 

category, and click Add. 

To assign access to a role: 

1. Log in as an administrator. Navigate to Configuration > Roles. 

2. Select a role by clicking on the row of the entry to modify. 

3. Select the Allowed Notes details. 

4. Either select All Notes or Enter a note category code to grant access to notes in a specific 

category, and click Add. 

Assigning Policies 
Policies are used to control access to certain features of LinkOne WebView. The same policies 

are available for each role and each user, and when enabled on a role, are inherited by users with 

that role. 

A typical user would probably not have any policies enabled, but an administrator would 

typically have all policies enabled. 

The policies that are supplied with the standard installation:  

Allow Category Writing 

Enabling this policy allows the assigned user or role to create and modify note categories in the 

book viewing web page. 

Allow Public Note Writing 

Enabling this policy allows the assigned user or role to create and modify notes that can be 

viewed publicly in the book viewing web page. 

Allow Supplied Note Writing 

Enabling this policy allows the assigned user or role to create and modify notes that are 

supplied with publishers, books, or pages, that can be viewed publicly in the book viewing web 

page. 

Allow Private Note Writing 

Enabling this policy allows the assigned user or role to create and modify notes that are viewed 

only by themselves in the book viewing web page. 
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Allow Multilingual Note Writing 

Enabling this policy allows the assigned user or role to create and modify note translations for 

other languages besides their current book language. 

Allow Selection List Sharing 

Enabling this policy allows the assigned user to see selection lists from other users that are in at 

least one of the roles the assigned user is in. 

Disable changing Password 

Enabling this policy stops the assigned user or users in the assigned role from changing the 

password from the 'My Profile' dialog. 
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